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Microsoft Access failed to start correctly - Error

by Michael W. Wass - November 3, 2007


SYMPTOMS

==========

When using Access 2002 on a Windows 2000 terminal server, you may receive the following error:

 

Access failed to start correctly last time. Starting Access in safe mode

will help you correct or isolate a startup problem in order to successfully

start the program. Some functionality may be disabled in this mode.

 

Do you want to start Access in safe mode?

 

You can click either Yes or No and Access opens. The next time you launch Access you are not given the prompt. However, at the next launch of Access you are given the prompt. On the following logon, you are not given the prompt. This loop of Access 2002 prompting for Safe Mode every other time you launch Access continues indefinitely.

 

CAUSE

=====

 

HKEY_LOCAL_MACHINE\Windows NT\Current Version\Terminal Server\Install\Software\Microsoft\Office\11.0\Access\Resiliency with the key TermSrvCopyKeyOnce with a value of 0x1 exists in the Registry on the Windows 2000 Terminal Server in one of the subkeys under Resiliency.

 

When Access 2002 starts, the following Registry key is created:

 

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Access\Resiliency.

 

NOTE: The Resiliency registry key for Access is new for Access 2002.

 

If no problems are encountered, the Resiliency key is deleted. If one of the many tests that Access makes at startup fail, subkeys are written under the Resiliency key and the Resiliency key is not deleted. If the key remains, the next start of Access 2002 gives the prompt.

 

If a subkey is deleted by an application from HKEY_CURRENT_USER (HKCU) -- specifically a subkey from HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Access\Resiliency while the server is in Terminal Server Install mode, the data is copied to HKEY_LOCAL_MACHINE (HKLM):

 

HKLM\Software\Microsoft\Windows NT\Current Version\Terminal Server\Install\Software\\Microsoft\Office\11.0\Access\Resiliency

 

When the application attempts with the server in Terminal Server Application Mode to access the key again and finds it missing, the application looks in this location (HKLM) for the key. If the Resiliency key is there and has the key TermSrvCopyKeyOnce under one of the subkeys of the Resiliency key, the Resiliency key is written back to HKCU.

 

In this case, the Resiliency key was written with subkeys while in install mode. Once the terminal server goes back to application mode every user is affected since Outlook 2002 always looks for the Resiliency key, thus causing the loop.

 

RESOLUTION

==========

 

Deleting HKLM\Software\Microsoft\Windows NT\Current Version\Terminal Server\Install\Software\Microsoft\Office\11.0\Access\Resiliency resolves the problem.

 

 

 
 
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